In this lab, you will generate several figures. Please sensibly name these images, save them as .png or similar, collect them into a single .zip file named xxxxxx_lab03.zip where xxxxxx is your last name, and e-mail them to gleggers@gatech.edu with the subject line of "[EAS 8803] Lab 03 Products."

Any files you need are at: http://wray.eas.gatech.edu/remotesensing2017/RS_lab03_files.zip.

1 Spectral Identification

Spectroscopy is a principal method we use to determine mineralogies at distance, and this section focuses on recognizing spectral features and identifying compositional causes. All mineral spectra in this section will have been encountered in some fashion in lecture or the Clark (1999) assigned reading and none are repeated. For each mineral spectrum, please:

(i) Describe the principal spectral features (e.g., wavelength, breadth, depth, shape, etc.).

(ii) Identify the causes of these features.

(iii) Discuss what compositions can be inferred.

For Questions 1 and 2, spectra are provided as two-column tab-delimited ASCII .TXT files. The first column is wavelengths in microns and the second column is reflectance ranging from 0 to 1. These spectra are from the USGS Spectral Library 7 and were taken under controlled laboratory settings, so noise should not be too much of an issue.

The spectra can be easily imported into ENVI. From the main toolbar, select Window → Start New Plot Window. On the new plot that opens, select File → Input Data → ASCII. In the file selection menu, navigate to the ASCII file of the spectrum to plot. In the new dialog box, select the appropriate wavelength units. Options to customize the plot can be found in the main plot window under Edit → Data Parameters and Edit → Plot Parameters. Additionally, multiple spectra can be input into a single plot window for direct comparison. These spectra can either be plotted with the same Y-Axis scale or the plots can be given an offset by left-clicking the plot window and choosing Stack Plots to rescale. If preferred, these spectra can also be imported into and plotted in other programs like Microsoft Excel or MATLAB.

1. These known minerals, found in the "knownMinerals" directory, are provided with their names. Please conduct the spectral analysis described above. For Question (1c) and (1d), specifically compare and contrast the two mineral spectra and their compositional interpretations.

   (a) KM.1 - Dolomite
   (b) KM.2 - Cinnabar
   (c) KM.3 - Enstatite vs. KM.4 Augite
   (d) KM.5 - Montmorillonite vs. KM.6 - Kaolinite

2. These unknown minerals, found in the "unknownMinerals" directory, are provided without their names. Please conduct the spectral analysis described above, and, if able, give the mineral name and formula for each spectrum. For Question (2d), specifically compare and contrast the two mineral spectra and their compositional interpretations.

   (a) UM.1
   (b) UM.2
   (c) UM.3
   (d) UM.4 vs. UM.5
For Question 3, physical specimens are provided and spectra will be taken using the Wray lab’s VNIR spectrometer. Please contact the TA to set up a time to use the spectrometer. The spectrometer software outputs spectra individually as two-column tab-delimited ASCII .SED files. The first column is wavelengths in nanometers and the second column is percent reflectance ranging from 0 to 100. These spectra can be imported into ENVI or other programs, but mind that these ASCII files have headers within them.

As our laboratory setting is not as controlled as the USGS, expect noise to be a factor. To combat this, use the spectrometer gun on as direct a mineral exposure as possible and take reference spectra often.

3. Please conduct the spectral analysis described above, and, if able, give the mineral name and formula for each spectrum. It may be useful to provide plots of the measured spectra that aided interpretation.

The mineral spectra for Question (3e) have not been seen in lecture or Clark (1999) and are for bonus.

(a) LM.1
(b) LM.2
(c) LM.3
(d) LM.4
(e) [BONUS] LM.5 (blue mineral) & LM.6 (green mineral)

2 CRISM Analysis

Spectral analysis is rarely just looking at an individual mineral spectrum and pointing out features. More often, we are interested in analyzing the identified mineral assemblages of hard-to-reach areas to infer the local geological history. In this section, you will conduct a basic spectroscopic analysis of a CRISM hyperspectral image near Isidis Basin on Mars using the CRISM Analysis Toolkit (CAT) extension for ENVI.

Data for this section is found in the "crism" directory. While the CRISM instrument provides separate visible and near-infrared data products, this analysis focuses on the near-infrared (≈ 1–2.6 μm). Remember that since CRISM is an active instrument operating from space, its observational environment is less controlled. Thus, expect there to be more noise in the spectra that can obfuscate interpretations as compared to the laboratory spectra encountered in the prior section. Finally, all principal mineralogies of this CRISM scene have been encountered in the prior section, at least in terms of general mineral classes.

2.1 Data Processing

Before the CRISM data can be analyzed, it must be processed through several steps.

(i) Conversion: CRISM data is stored in a Planetary Data System (PDS) format and must be converted to an ENVI format for analysis. From the main ENVI toolbar, select CAT → Convert Format: PDS to CAT. In the selection menu, navigate to the data directory and select the "*TRR3.img" file. In the new dialog box, output results to a file.

(ii) Atmospheric Correction: To atoaspherically correct the data, from the main ENVI toolbar select CAT → ATP Corrections. In the dialog box, select On for Photometric correction and Division by scaled volcano observation for Choose atmospheric correction. On the next menu, select Default volcano scan 61C4 on the next menu. Then, select New McGuire 2-wavelength and Enable artifact correction? on the following menu. Finally, select the "*_CAT.img" file and output the result to a file.

(iii) Summary parameters: Summary parameters will help guide subsequent analysis. From the main ENVI toolbar select CAT → Spectral Analysis Utilities → 2014 Summary Products → IR Data. In the file selection menu, select the "*_corr.img" file, and in the following dialog box select All parameters. Output the result to file.

(iv) Data filtering: To clean up the summary parameters, from the main ENVI toolbar select CAT → Data Filtering → Flatten Summary Products. Select the "*_2014params.img" file and output the result to a file.
(v) **Map projection:** To project the CRISM data into map coordinates, from the main ENVI toolbar select CAT → Map Utilities → Project Single Cube Data. Select the "*_cor.img" file and output the result to a file. Repeat for the "*_flat.img" file.

With this, the basic CRISM data analysis is complete. Feel free to close all files but the map projected images, i.e. the "*_p.img" files.

### 2.2 Parameter Analysis

CRISM summary parameters serve as quick approximations of the full measured spectrum at every pixel. For example, the BD1400 parameter is a calculation of the relative depth of the spectrum at \( \approx 1.4 \, \mu m \) compared to other wavelengths. Recall that absorption features at 1.4 \( \mu m \) are due to OH vibrations, so a BD1400 parameter map can be a proxy for hydrated or hydroxylated minerals. See Viviano-Beck et al. (2014) for detailed descriptions of these parameters, including how they are calculated and what they measure.

These parameters are not absolute, however, and any mineral identification should be confirmed by direct analysis of spectra. While these summary formulas calculate a parameter value at every pixel, not all pixels may actually contain that composition. However, it is reasonable that the pixels with the highest parameter values have a greater probability of exhibiting the desired compositions.

(i) Display a parameter as a grayscale image. Lighter areas represent higher parameter values and darker areas represent lower parameter values.

(ii) Display a three-parameter set as Red, Blue, and Green to make a color image. Areas of single colors have high values for only one parameter while mixed color areas have higher values in multiple parameters.

(iii) These parameter values are only necessarily high relative to one another, however. Stretch the individual parameters currently displayed such that only the highest values appear by selecting **Enhance → Interactive Stretching** from the main image toolbar. Now, the areas displaying color have the best chance of holding compositions of interest.

(iv) Repeat this process for other interesting parameters until an understanding of the potential compositional diversity of the scene is gained.

4. Produce a stretched three-color parameter map that highlights the compositional diversity of the scene. Please e-mail your image and briefly discuss the parameters you chose.

### 2.3 Identifying Regions of Interest

Once parameter analysis has highlighted areas of interesting compositions, those areas can be isolated as Regions of Interest (ROIs) for spectral analysis. This process is essentially drawing a shape around pixels within the interesting area and then computing statistics for just those pixels.

There are a few caveats as to what makes a good ROI. First, while they should tightly focus on an area, the ROIs also be somewhat large (10s of pixels) so that the averaging process tamps down random noise. Second, it is wise to do a couple ROIs for the same interesting areas to provide confirmations of any notable identifications. Third, some ROIs should be made over areas that appear bland—either covered in dust in the original CRISM image or that shows no strong parameter values. These bland ROIs will be used as comparisons to the other ROIs to remove background trends.

ROIs can be drawn on either the CRISM image itself or on the parameter map image (or both), but it is generally easier to draw them on the parameter map (so as to focus on the strongest areas) and then import them to the CRISM image proper.

(i) To open the ROI menu, image toolbar select **Tools → Region of Interest → ROI Tool**.

(ii) Choose the **Window** on which to draw ROIs (Image, Zoom, etc.). Under **ROI Type** are options for the ROI shape (Polygon, Rectangle, etc.).

(iii) For the **Polygon** option, select the area to be encompassed as an ROI by clicking points for the polygon vertices vertices, left-clicking twice to finish the shape. Alternatively, click once and drag for the **Rectangle** option, left-clicking once to finish the shape.
(iv) Select New Region and repeat for more ROIs. Once an ROI is finished, it is customizable by double-clicking the default ROI Name or left-clicking the default Color.

(v) When finished, save the ROIs. In the ROI Tool dialog, select File → Save ROIs. Choose Select All Items, give it a file name, and then save.

(vi) To load ROIs into the CRISM image, from the image window toolbar select Tools → Region of Interest → ROI Tool.

(vii) In the menu, select File → Restore ROIs and then choose the appropriate file.

(viii) To generate statistics for the ROIs, in the ROI Tool menu choose Select All then then Stats.

5. Produce an image of the CRISM image overlain by your ROIs. Please e-mail your image and briefly discuss why you placed the ROIs where you did.

2.4 Producing Spectra

The statistics for an ROI represent a summary description of the pixels within the ROI. In particular, the ROI mean represents the region's "average spectrum." Viewing these means requires using spectral math.

(i) From the main ENVI toolbar, select Spectral → Spectral Math.

(ii) Enter the expression "s1" in the dialog box and then select it.

(iii) In defining the "s1" variable, choose the an ROI mean. Output the result to New Window.

(iv) The plotted spectra may not be apparent at first. In the plot window, select Edit → Plot Parameters. Restrict the X-Axis range to 1 to 2.6 µm. Then, left-click the plot and choose Stack Plots to rescale. Repeat this to exit stacking mode.

(v) Repeat for one other ROI. Output it to the Same Window.

The two spectral plots likely look similar because outside of compositionally extreme areas, much of Mars has a general reddish spectroscopic look. This is where the bland ROIs identified earlier come in. By ratioing interesting areas with bland areas, i.e. dividing the average spectrum of the interesting ROI (the numerator) by the average spectrum of the bland ROI (the denominator), the background can be removed and subtler spectral features enhanced.

(i) From the main ENVI toolbar, select Spectral → Spectral Math.

(ii) Enter the expression "s1/s2" in the dialog box and then select it.

(iii) In defining the "s1" variable, choose the the same ROI mean as before. For "s2," however, choose one of the bland ROIs. Output the result to New Window

(iv) Edit the plot parameters as before. Consider how the plotted spectrum looks different.

(v) Repeat this for ROIs over other interesting areas of the image. Keep track of the spectra you produce and any interesting mineralogies they reveal.

A word of caution, however: if a bland area is poorly chosen and has strong absorptions, these features can either cancel out similar absorptions in the numerator or appear as peaks in the ratioed spectrum.

6. For a single ROI, produce a spectral plot of both the unratioed and ratioed spectrum. Provide these plots, noting which ROI the plots are for and briefly discuss the key differences between the plots.

2.5 Putting it All Together

7. Given all the spectra examined over the spatial extent of this CRISM scene, synthesize your analysis.

   (a) What is the principal mineralogy of this area in terms of general mineral classes?

   (b) Can any specific minerals be identified?

   (c) What are the principal spectral features that aided in interpretation?

   (d) Provide the spectral plots derived from the CRISM image that aided in interpretation. Remember to label the ROIs from which the plots are derived and provide any clarifying annotations.

8. [Graduate Students] Hypothesize a formation environment for this area. How do your mineralogic interpretations contribute to this hypothesis?